A lot of licensed and some free of cost script-driven applications have encrypted program code, which is not human readable. The idea behind this is to avoid the reverse engineering and the unauthorized use of such apps. One of the most popular encryption instruments used for this specific purpose is called Zend Guard and it's used widely because it can be used to alter any type of PHP 4 or PHP 5 code. The only method for the encrypted files to work correctly on a web server afterwards is if a second tool called Zend Optimizer is available. If you'd like to use any paid web software that requires Zend Optimizer, you should make sure that it's set up on the server where you'll host your website. In addition, websites that need the tool can perform better due to the fact that their code is already precompiled and optimized, which means that it is executed quicker.

Zend Optimizer in Cloud Web Hosting

Zend Optimizer is installed on all the servers which are part of our modern cloud website hosting platform. No matter which Linux cloud web hosting you select, you will be able to activate the tool to guarantee that any kind of script app that needs it will function properly in your account. By using a handy software instrument from the Advanced area of the Hepsia Control Panel that comes with all the web hosting accounts, you'll be able to activate and deactivate various functions with a button. Zend Optimizer will be one of them, so even if this happens to be your first website hosting account ever, you won't experience any troubles. In the same area you can also choose the PHP version for your account - 4 and numerous versions of 5, so any time you change to one that you have not used yet, you can activate Zend Optimizer for it with a click. Because our platform allows you to employ multiple PHP versions at once, more experienced users can activate the tool for an individual website with a php.ini file in a specific domain folder as well.

Zend Optimizer in Semi-dedicated Hosting

Zend Optimizer is available on all the servers that comprise our cluster website hosting platform, therefore you will be able to use it for all your script-driven applications with any of our semi-dedicated server packages. It is available at all times even when you switch the PHP version for your account as our feature-rich platform will allow you to select from PHP 4, 5.2, 5.3, 5.4 and 5.5. Both changing the version and activating Zend Optimizer for the new one takes a few clicks in the PHP Configuration area of the Hepsia hosting Control Panel that is used to manage the semi-dedicated accounts. In addition, you may even employ a different version of PHP and activate or deactivate Zend for each individual domain that you host in the account. You can do this by using a php.ini file in a domain folder with just a few lines of code in it. If you do not have previous experience and you are unsure how to do this, our 24/7 technical assistance can help you.